ROSE  0.9.9.149
Installing Python

Instructions for installing Python, a ROSE software dependency.

If you encounter the error "configure: error: this package requires Python >= 0.0.0 and < 3.1.4." when configuring ROSE, then edit $ROSE_SRC/config/support-rose.m4 and change "[3.1.4]" to "[4.0.0]" and then rerun ROSE's "build" and "configure" steps.

Red Hat Enterprise Linux 7

Run yum install python-dev as the administrator.

Debian 7 "Wheezy"

Run apt-get install python3-dev as the administrator.

Debian 8 "Jessie"

Run apt-get install python3-dev as the administrator.

Ubuntu 14.04 "Trusty Tahr"

Run apt-get install python3-dev as the administrator.

Ubuntu 16.04 "Xenial Xerus"

Run apt-get install python3-dev as the administrator.

Collaboration diagram for Installing Python: